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Configuration of COMSOL Multiphysics for
simulating axisymmetric dielectric resonators:
explicit weak-form expressions axisymmetric

electromagnetic resonators
Mark Oxborrow

APPENDIX I

It is here explained, in some detail, how to set up a
dielectric-resonator simulation in COMSOL Multiphysics [1]
–from scratch. These explanations should also be helpful
to anyone wishing to modify one of the author’s existing
models –as incarnated in an .MPH file. At least in the first
instance, it is recommended that the following instructions be
meticulously adhered to –lest one stray from a tried-and-tested
path. And it is suggested that the reader work through them
with COMSOL Multiphysics open and running on his/her
desktop. All menu items, expression names and variables
associated with the program are displayed intyped text
font. A good deal of supplementary information can be found
in the documentation supplied with COMSOL Multiphysics
itself; the author found the following chapters therein to be
the most useful/relevant:‘PDE Modes for Equation-Based
Modeling’, ‘The Weak Form’, and ‘COMSOL Multiphysics
Scripting’. Upon reading these chapters, one might be left
with the impression that COMSOL is simply not sufficiently
flexible to embrace the task in hand (i.e. to implement sec-
tions II through IV of this article explicitly); the following
instructions demonstrate how COMSOL Multiphysics can,
despite these first impressions, and most straight-forwardly,
be so configured to implement the 2D simulation of isotropic
dielectric resonators. From the beginning then:

A. Setting up –fundamentals

Get COMSOL Multiphysics up and running. Access the
Model Navigator panel via File ⇒ New ... and
select theNew tab if not already selected.

(a) Select ‘2D’ from the Space dimension: drop-down
menu [note: donot choose ‘Axial symmetric (2D) ’].

(b) Browse to and select ‘COMSOL Multiphysics
⇒ PDE Modes⇒ Weak Form, Subdomain ’ from the
Application Mode navigator.

(c) Type (verbatim) ‘Hrad Hazi Haxi ’ into the
Dependent variables: text field. These three variables
are the radial, azimuthal and axial components of the magnetic
field strength, respectively; all three are dependent on (i.e. are
functions of) the Cartesian coordinates for the COMSOL
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simulation’s 2D space, namelyx (horizontal on the screen)
andy (vertical) –both in units of metres [m]. The coordinate
names ‘x ’ and ‘y ’ are already fixed by COMSOL (i.e. they
are reserved symbols) and need not be explicitly entered (in
COMSOL terminology,x andy are ‘geometric variables’).

(d) For theApplication mode name: (defaultu) one
can type in anything one likes.

(e) Select ‘Lagrange - Quadratic ’ from the
Element: drop-down menu. [This choice is proven to
work.]

B. Constants

All of the various constants (i.e. independent ofx or y )
included within the weak-form expressions given below are
defined and described in TABLE I. The equivalent of this table
needs to be typed (or loaded) into COMSOL’sOptions ⇒
Constants ... . EachExpression thusValue therein
[except those fore0 , eperp0 , epara0 –which define the
(unit) relative permittivity of free-space], can be user-varied.
But everyNameshould be entered verbatim;i.e., each constant
must be named exactly as it appears in the expressions that
subsequently include it.

C. Expressions (for Postprocessing)

The post-processing of the calculated magnetic-field
strength (as a function of position) for each solved eigen-
function is facilitated through the various definitions presented
here.

1) Scalar expressions:The equivalent of TABLE II
(or some subset thereof) needs to be typed into
COMSOL’s Options ⇒ Expression ... ⇒
Scalar expressions ... .

2) Subdomain expressions: The functionality of
Subdomain expressions is required for generating
post-processed fields, like the electric field strengthE –as per
the 6th, 7th and 8th entries in TABLE II. Those constants
associated with each such field’s definitions, like (in the case
of E) the relative permittivitiesepara and eperp , vary
from one subdomain within the medial half place to another.
The variation of these subdomain-dependent ‘constants’
is represented throughOptions ⇒ Expressions ⇒
Subdomain expressions ; therein, theName of each
such variable is the same in each and everySubdomain
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(as identified by an integer), but itsExpression reflects
the variable value in the selectedSubdomain . Thus, the
Expression for epara in a Subdomain corresponding
to (cryogenic and axisymmetrically oriented) sapphire would
be epara1 , with epara1 defined (globally) as 11.3486
(or whatever) through TABLE I, whereas in aSubdomain
corresponding to free space, theExpression for epara
should be set to1. Similarly (and more simply), the single
Subdomain -dependent variableerel can be used to
represent the variation of relative permittivity within an
axisymmetric resonator containing solely isotropic dielectrics
(incl. free space).

D. Weak-form expressions

The simulation’s defining weak-form expressions are set
up through thePhysics ⇒ Subdomain Settings ...
control panel. On the left of this panel, first select theGroups
tab. ANew Group must be named and defined for each dielec-
tric within the resonator being simulated. The author chose to
name these dielectricGroups ‘dielectric_0:vacuum ’,
‘dielectric_1 ’, ..., ‘dielectric_n ’, ... . For each
dielectric Group , (in general) dielectric_n say, cor-
responding weak-form expressions need to be entered into
the weak terms (i.e. three slots or text fields), for ex-
pressions involving spatial derivatives, and also into the
dweak terms , for expressions involving temporal deriv-
atives; these slots are accessed through theweak and
dweak tabs, respectively, located on the right of the
Subdomain Settings ... control panel. These terms
govern the electromagnetic field in regions filled with the
n-th dielectric, as specified in theConstants ... ta-
ble introduced above. No other fields on the right of
Subdomain Settings ... need(/should) be touched; in
particularly, don’t monkey with thecontr -tabbed sub-panel.
Note that it is imperative that theName of each constant
entered intoOptions ⇒ Constants ... above match
(verbatim) its appearances within the expressions (below) that
are entered into theweak and dweak text fields here. For
each dielectricGroup , two weak and onedweak terms are
required: (i) a ‘Laplacian’ term (corresponding to the left most
term on the left-hand side of equation 6 in the main paper and
(ii) a ‘penalty’ term, included to suppress spurious modes,
corresponding to the middle term of the same.

1) Laplacian term [first weak-term slot]:: The form of the
Laplacian weak term,(∇××× H̃

∗
) ·ε (∇×××H), here given for the

1st axisymmetric dielectric, is1

((eperp1 * (test(Hazi) * Hazi
-M* (test(Hazi) * Hrad
+Hazi * test(Hrad))
+Mˆ2* test(Hrad) * Hrad)
+epara1 * Mˆ2* test(Haxi) * Haxi)/x
+eperp1 * (test(Hazix) * (Hazi-M * Hrad)
+Hazix * (test(Hazi)-M * test(Hrad)))
-epara1 * M* (test(Haxi) * Haziy
+Haxi * test(Haziy))
+x* (eperp1 * test(Hazix) * Hazix
+epara1 * ((test(Haxix)
-test(Hrady)) * (Haxix-Hrady)
+Haziy * test(Haziy)))
)/(epara1 * eperp1)

(I.1)

where Hazix denotes the partial derivative ofHazix with
respect to the coordinatex , Hrady the partial derivative
of Hazi with respect toy , etc.; test(Hazi) denotes
the ‘test function’ ofHazi , etc. Its equivalent for the 2nd
axisymetric dielectric is obtained by replacingeperp1 by
eperp2 andepara1 by epara2 , and so forth for all other
axisymetric dielectrics (should more be required). The above
expression can be significantly simplified for the (subdomain)
Groups corresponding to isotropic dielectrics or free space
(viz.dielectric_0 ); for computational efficiency, it is rec-
ommended that these simplifications be implemented wherever
possible. The required form of the Laplacianweak term ,
[(∇ ××× H̃

∗
) · (∇ ××× H)]/ε1, for the 1st isotropic dielectric is

given explicitly as

((test(Hazi) * Hazi
-M* (test(Hazi) * Hrad
+Hazi * test(Hrad))
+Mˆ2* (test(Hrad) * Hrad
+test(Haxi) * Haxi))/x
+(test(Hazix) * (Hazi-M * Hrad)
+Hazix * (test(Hazi)-M * test(Hrad)))
-M* (test(Haxi) * Haziy
+Haxi * test(Haziy))
+x* (test(Hazix) * Hazix
+((test(Haxix)
-test(Hrady)) * (Haxix-Hrady)
+Haziy * test(Haziy))))/e1 ,

(I.2)

wheree1 is the material’s dielectric constant (as appearing in
TABLE I). The Laplacianweak term for the vacuum is the
same withε1 → 1, and those for other isotropic dielectrics are
similarly obtained by swoppingε1 with ε2, ε3, and so forth.

2) Penalty (divergence-suppressing) term [second weak-
term slot]: : The form of the penaltyweak term , α(∇ ·

1Note that, when typing (or ‘cutting-and-pasting’) this and the following
(d)weak-form expressions into their slots,all spaces and new linesmust be
eliminated from the whole expression within each slot –otherwise COMSOL
will reject the expression.
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H̃
∗
) · (∇ · H), the same for each subdomainGroup , is

alpha * ((test(Hrad) * Hrad
-M* (test(Hazi) * Hrad
+Hazi * test(Hrad))
+Mˆ2* test(Hazi) * Hazi)/x
+(test(Haxiy)
+test(Hradx)) * (Hrad-M * Hazi)
+(test(Hrad)-M * test(Hazi))

* (Hradx+Haxiy)
+x* (test(Hradx)
+test(Haxiy)) * (Hradx+Haxiy))

(I.3)

here, the coefficientalpha (whose value is determined
through COMSOL’s equivalent of TABLE I) controls the
aggressiveness of the divergence suppression induced by this
term. The remaining, 3rd slot, should be zero-filled. [As a
general rule, unused weak-form slots should always be filled
with zeroes –this applies to the thedweak term slots below.]

3) Frequency term [first dweak-term slot]:The form of the
temporal-derivative/frequency (so-called ‘dweak’) term̃H

∗ ·
∂2H/∂2t, common to all subdomainGroups , is entered into
the first slot within thedweak -tabbed panel ofPhysics ⇒
Subdomain Settings ... , and is given as

cbar2 * x* (Haxitt * test(Haxi)
+Hazitt * test(Hazi)
+Hradtt * test(Hrad)) ,

(I.4)

whereHaxitt denotes the double partial derivative ofHaxi
with respect to time,etc. The remaining 2nd and 3rd slots of
the dweak -tabbed panel should be zero-filled.

E. Boundary conditions

Here the constraints stated in subsection II.C of the
main paper are expressed in COMSOL-ready forms. The
model resonator’s boundary conditions are defined through
the Physics ⇒ Boundary Settings ... control
panel. On the left of this panel, select theGroups
tab. Each named boundaryGroup here corresponds to
a particular electromagnetic boundary condition, the most
essential of which are described here. These different
e.m. boundary conditions are specified by the expres-
sions that populate the three slots within their respective
contr -tabbed sub-panels, located on the right-hand side of
Boundary Settings ... ; ‘contr ’ here stands for ‘con-
straint’. [The neighboringweak-tabbed anddweak -tabbed
panels within theBoundary Settings ... need not be
touched (and left zero-filled).]

1) Electric wall (for a bounded isotropic dielectric):

Hrad * nx+Haxi * ny ; (I.5)

-Haxix+Hrady ; (I.6)

(Hazi * nx-Hrad * M* nx
-Haxi * M* ny+Hazix * nx * x

+Haziy * ny * x)/x ;
(I.7)

herenx andny are, as ‘geometric variables’ within COMSOL
(in 2D), the components of the (outward) unit normal vector
on the boundary of a subdomain.

2) Magnetic wall (for a bounded isotropic dielectric):

Haxi * nx-Hrad * ny ; (I.8)

Hazi ; (I.9)

(Haxi * M* nx+Hazi * ny
-Hrad * M* ny-Haziy * nx * x

+Hazix * ny * x)/x .
(I.10)

3) Radiation match (in free-space):As has already been
discussed in subsection II.C of the main paper, the constraints
appropriate to implementing a radiation match, can be re-
garded (complex) linear combinations or ‘mixings’ of pure
electric- and magnetic- wall constraints. The first constraint
mixes the magnetic-wall constraint 23 in the main paper,
i.e. I.9 above, with the electric-wall constraint 20 in the main
paper,i.e. I.7 above:

-i * cMW* Hazi * cbar * mf
+cEW* (Hazi * nx-Hrad * M* nx
-Haxi * M* ny+Hazix * nx * x
+Haziy * ny * x)/x ;

(I.11)

note that ‘i ’ here is the square root of minus one. And the
second constraint mixes the electric-wall constraint 18 in the
main paper,i.e. I.6 above, with the magnetic-wall constraint 22
in the main paper,i.e. I.8 above:

-i * cEW* (-Haxix+Hrady)
+cMW* cbar * mf* (Haxi * nx-Hrad * ny) .

(I.12)

Here, the pair of constants{cMWand cEW}, are defined
through TABLE I. When they are set to their standard (default)
values of{ 1/

√
2, 1/

√
2 }, equations I.11 and I.12 impose

a radiation match on tangential field components at the im-
pedance of plane e.m. waves in free-space. Here also,cbar =
c̄ ≡ 2π/c; andmf is the mode’s (center) frequency; both need
to be defined withinOptions ⇒ Constants ... . –as per
their corresponding rows in TABLE I;

The final (optional) constraint mixes the electric wall con-
straint 17 in the main paper,i.e. I.8 with the magnetic wall
constraint 21 in the main paper,i.e. I.10:

tngM * cbar * mf* (Hrad * nx+Haxi * ny)
-tngE * (Haxi * M* nx+Hazi * ny
-Hrad * M* ny-Haziy * nx * x
+Hazix * ny * x)/x .

(I.13)

Here; the constantstngM andtngE , are also defined through
TABLE I and thereuponOptions ⇒ Constants ... .
Setting{tngM , tngE } = {1,0}({1,0}) constrains the magnetic
(electric) field to be wholly tangential on the impedance-
matching plane as is characteristic of electromagnetic trav-
eling waves. The default setting for this third constraint was
(arbitrarily) {tngM , tngE } = {1,0}). [It is remarked here
that the author sought to implement the radiation-matching
constraints more directly and elegantly with time derivatives,
i.e., replacing2* pi * mf* Hazi by Hazit , and similarly for
Hrad andHaxi . But COMSOL did not generate the intended
frequency factor when interpreting them. He thus resorted to
entering the expressions as stated in equations I.11 through
I.13, requiringmf to be set, by hand, for each mode.]
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F. Geometry

Each resonator’s geometry needs to be either constructed
within or imported into COMSOL. COMSOL’s manual pro-
vides instructions on how to implement both. Though simple
geometries (e.g. a cylinder of solid dielectric material inside
a cylindrical metal can) can be quickly constructed by hand
within COMSOL, the author found it advantageous to define
the sets of quadrilateral subdomains into which many axisym-
metric dielectric resonators can be readily decomposed using
MATLAB scripts, where the script was run to generate the
resonator’s medial cross-section. The key lines in these scripts
were those of the form

q1 = poly2vert([[x1,y1];
[x2,y2];[x3,y3];[x4,y4]]);

this particular line defines a quadrilateral, namedq1 ,
whose vertices have thex-y coordinates:[x1,y1], ...
[x4,y4] . These quadrilaterals could then be imported into
COMSOL by entering a list comprising their names into
File ⇒ Import ⇒ Geometry Objects . Each complete
MATLAB script (also available from the author upon request)
included, where known/relevant, the cryogenic shrinkages of
the resonator’s constituent materials.

G. Meshing

If constructed out of quadrilaterals, the resonator’s geometry
can be meshed either into sub-quadrilaterals usingMesh ⇒
Map Mesh. Else, the geometry can always be meshed into
(psuedo-random) triangles usingMesh ⇒ Initial Mesh
with (recommended) mesh refinement over selected areas
(covering the bright spots of WG modes). Note that, for the
geometry to beMap Mesh-able, the vertices of its inter-
nal quadrilaterals should generally all meet at ‘cross-roads’,
where, at each, four vertices belonging to four separate quadri-
laterals all meet at a point, as opposed to ‘T-junctions’, where,
at each, two vertices belonging to two separate quadrilaterals
meet at a point along the boundary edge of a third quadrilat-
eral. The reader is advised to consult the COMSOL manual
(chapter ‘Meshing’, section ‘Generating Meshes’, subsection
‘Creating Mapped Meshes in 2D’) for a fuller (though a
still not wholly satisfactory) explanation of this rather quirky
requirement. The meshing density can be controlled by, for
selected edges, activating and entering an appropriate integer
in the ‘Contrained edge element distribution ’
field within of theBoundary tab of theMap Mesh control
panel. With regard to bothMap Mesh-ability and control over
meshing density, it can be advantageous (or plain necessary)
to divide odd-shaped subdomains (e.g. an ‘L’-shaped region
covered throughout by a single spatially uniform dielectric ma-
terial) into several, more simply shaped adjoining subdomains
(e.g., in the case of dividing up the L-shaped subdomain, two
or even three rectangular subdomains). Note that the geometry
will not mesh if the allocations of elements along too many
edges are (inconsistently) specified; in other words, the edge
element distribution must not be over constrained.

H. Assignments

1) Interiors of subdomains:The (either hand-made or
imported) quadrilaterals composing the resonator’s cross-
sectional geometry are assigned to one of the defined
dielectric Groups via the Subdomain Settings ...
⇒ Subdomains tab. Activating (i.e. ticking) the
Select by group option here aids the verification
of assignments.

2) Edges of subdomains:The external edges of quadri-
laterals should be set be obey one of the three above-
describedGroup boundary conditions via thePhysics
⇒ Subdomain Settings ... ⇒ Subdomains tab.
COMSOL appears to be smart enough to recognize those
edges that are external on its own accord and automatically
‘ghosts’ (grays) internal edges; the latter should not be as-
signed to any boundaryGroup condition. Thus, with the
Select by group feature activated, all the appropriate
edges can be assigned to the appropriate (usually electric-wall)
boundary condition in a single selection of theGroups drop-
down menu.

I. Solution

In Solve ⇒ Solve Parameters :
(a) set the selectedSolver: to ‘Eigenvalue: ’;
and, with theGeneral tab selected,
(b) set theDesired number of eigenvalues: to

‘10’ –or whatever ones desires;
(c) setSearch for eigenvalue around: to ‘0’ –or

whatever;
(d) set Linear system solver: to

‘Direct (SPOOLES) (this is at least the author’s
starting recommendation);

(e) setMatrix symmetry: to Symmetric ’.
Having implemented all of the above, one should now be

able toSolve ⇒ Solve Problem .

J. Postprocessing

COMSOL Multiphysics’ standard documentation explains
how to configure and use of thePostprocessing ⇒
Plot Parameters control panel. Only a few specific
pointers are supplied here:

[1] The center frequencies of solved resonances can be
viewed through theSolution to use ⇒ Eigenvalue:
drop-down menu in theGeneral -tabbed sub-panel of the
Plot Parameters control panel.

[2] To display the morphology and features of the solved
eigenmodes, theExpression: slot within the Surface -
tabbed sub-panel of the same is filled with either (i) some
function of the solved field variables{Hrad , Hazi , Haxi } or
(ii) one of those expressions (e.g.ElecMagSqrd ) pre-defined
in Options ⇒ Expressions Scalar Expressions
as COMSOL’s equivalent of TABLE II, or (iii) some func-
tion/combination thereof. For example,

log10(AbsMagEnDens+10ˆ(-10)) (I.14)

can be inserted to view the magnetic energy density on a
logarithmic scale. To view (as a diagnostic) the divergence
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of the magnetic field strength, which should be zero, one
insertsDivH ≡ (Hrad-Hazi * M+(Haxiy+Hradx) * x)/x
instead.

[3] Determinations of an electromagnetic mode’s volume,
filling factor(s), and length (Λ), as per equations 24 ,
25 , and 27 , respectively, in the main paper, all make
use of thePostprocessing ⇒ Domain Integration
panel. For example, the numerator

∫ ∫ ∫
h.−s.

ε|E|2dV on
the right-hand-side of equation 24 in the main pa-
per can be evaluated by insertingElecEnDens ≡
Erad * Drad+Eazi * Dazi+Eaxi * Daxi into this panel’s
Expression: slot, with those entries selected in the
Subdomain selection list on the left-hand side of the
same panel covering all significant parts of the mode’s bright
spot.

[4] With regards to determining filling factors, the numerator
on the right-hand side of equation 25 in the main paper can
be evaluated by selecting only those subdomains filled with
the relevant dielectric (as opposed to free-space).

[5] To determine the resistive-wall-loss integral∫ |n ××× H|2dS (forming the denominator of
equation 27 in the main paper ), one uses the
Postprocessing ⇒ Boundary Integration
panel with 2* pi * x* (abs(Hazi)ˆ2 +abs((Haxi * nx
-Hrad * ny))ˆ2) inserted into theExpression: slot
within the Expression to integrate box therein,
and where entries selected withBoundary selection
correspond to the resonator’s enclosing (metallic and lossy)
surfaces.

[6] The maximum/minimum of a field variable, as required
to evaluate the denominator on the right-hand side of equa-
tion 24 in the main paper , can be determined through the
Postprocessing ⇒ Plot parameters ⇒ Max/Min ,
wherein the Expression: slot is filled with the field
variable’s expression (viz. ElecEnDens for evaluating said
denominator).
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TABLE I

COMSOL CONSTANTS–INCLUDED IN WEAK -FORM EXPRESSIONS

Name Expression Description [unit]
(= value)

c 299792458 speed of light (exact) [m/s]
cbar 2 * pi/c frequency constant [s/m]

( = 2.095845e-8)
cbar2 4 * piˆ2/cˆ2 frequency constant [s2/m2]

( = 4.392566e-16)
alpha 1.0 penalty-term coefficient
M 9 azimuthal mode order
e0 1.0 relative permittivity

of free-space
e1 n_AlGaAsˆ2 relative permittivity of

( = 11.2896) isotropicdielectric1
e2 1.0 same but of

isotropic dielec.2
e3 1.0 etc.
eperp0 1.0 relative permittivity

of free-space
in directions transverse
to cylindrical axis

epara0 1.0 same but in direction
parallel to cylindrical axis

eperp1 9.2725 relative permittivity of
uniaxial dielectric1
in directions transverse
to cylindrical axis

epara1 11.3486 same but in direction
parallel to cylindrical axis

epara2 1.0 relative permittivity of
uniaxial dielectric2
transverse to cyl. axis

eperp2 1.0 same but parallel to
cylindrical axis

eperp3 1.0 etc.
epara3 1.0 etc.
e_293K_alumina 9.8 relative permittivity of

alumina at room temperature
epe_4K_sap_UWA 9.2725 UWA values for cryogenic

HEMEX sapphire
epa_4K_sap_UWA 11.3486
epe_293K_sap 9.407 nominal room temperature

values for same
epa_293K_sap 11.62
epe_4K_sap_NPL 9.2848 Values fitted to

NPL Cs-fountain
HEMEX resonator

epa_4K_sap_NPL 11.3660
n_silica 1.4457 refractive index of

thermally grown
silica (Fig B.2, p. 172 of
ref. [2])

n_AlGaAs 3.36 average refractive index of
GaAs and AlGaAs layers
(p. 172 of ref. [3])

mf 2.374616e14 match frequency
ttgH 1 toggle
ttgE 0 toggle
mix_ang 45 electric-magnetic mixing

angle (in degrees)
cMW sin(mix_ang

* pi /180) magnetic-walled-ness
(= 0.707107)

cEW cos(mix_ang
* pi /180) electric-walled-ness

(= 0.707107)
tngM 1
tngE 0
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TABLE II

COMSOL SCALAR EXPRESSIONS–FOR POSTPROCESSING

Name Expression
(Description)

DivH (Hrad-Hazi * M+(Haxiy+Hradx) * x)/x
(divergence of magnetic field –should be zero!)

MagEnDens Hrad* Hrad+Hazi * Hazi+Haxi * Haxi
(magnetic energy density)

Drad (Haxi * M-Haziy * x)/x
(radial component of electric displacement)

Dazi -Haxix+Hrady
(azimuthal component of electric displacement)

Daxi (Hazi-Hrad * M+Hazix * x)/x
(axial component of electric displacement)

Erad Drad/eperp
(radial component of electric field strength)

Eazi Dazi/eperp
(azimuthal component of electric field strength)

Eaxi Daxi/epara
(axial component of electric field strength)

ElecMagSqrd Erad * Erad+Eazi * Eazi+Eaxi * Eaxi
(electric field strength magnitude squared)

ElecEnDens Erad * Drad+Eazi * Dazi+Eaxi * Daxi
(electric energy density)

AbsMagEnDens abs(Hrad)ˆ2+abs(Hazi)ˆ2
+abs(Haxi)ˆ2
(absolute magnitude energy density)

MagNrmlHSqrd 2 * pi * x* abs(Haxi * ny
+Hrad * nx)ˆ2
(magnitude normal mag. field strength squared)

MagTngHSqrd 2 * pi * x* (1 * abs(Hazi)ˆ2
+1* abs(Haxi * nx-Hrad * ny)ˆ2)
(magnitude tangential magnetic field squared)

AbsElecSqrd abs(Erad)ˆ2+abs(Eazi)ˆ2
+abs(Eaxi)ˆ2
(absolute electric field squared)


